Error Installing Application on IIS – very annoying


The application ‘/XXX’ belonging to site ‘2’ has an invalid AppPoolId ‘XXX’ set.  Therefore, the application will be ignored.

Pesan error di atas sangat menyebalkan sekali. Membuat saya kehilangan 3 hari hanya untuk memecahkan permasalahan saat menginstal aplikasi web di IIS 7.0. Pada saat instalasi hint yang diberikan adalah coba buka Event Viewer dan ikuti langkah pada event viewer tersebut untuk mengatasi masalah di atas. Setelah saya buka event viewer error message yang tertera adalah seperti di atas.

Jadi apa yang harus saya lakukan? Di bagian mana kah yang salah? Apakah ada salah configurasi pada installer nya atau ada file yang corrupt pada installer? Setelah meminta bantuan pada Om Google baru lah terpecahkan masalah-nya. Permasalahan nya adalah karena di Windows Server 2008 R2 – .NET Framework yang terinstall adalah 4.0 – Sedangkan pesan error di atas mengindikasikan bahwa program yang ingin di install membutuhkan .NET Framework 3.5.

Masalah solved hanya dengan menginstall .NET Framework 3.5, tanpa harus merubah privilege user apa pun juga. Yang membuat menjadi annoying nya adalah bagaimana caranya bisa tahu kalau program tersebut membutuhkan .NET Framework 3.5 dari error code di atas…

Advertisements

One thought on “Error Installing Application on IIS – very annoying

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s